Thread Rating:
  • 3 Vote(s) - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official mGBA Ports
(08-06-2015, 11:04 PM)endrift Wrote: Nintendo 3DS
Old builds: alpha 1 (ef9bb6a)

Is this build way outdated?  Is there a way to remove smoothing when the screen is stretched out on 3DS
Reply
This build is ancient. Please use either the stable build or a development build from the downloads page.
Reply
I downloaded the latest nightly build of mGBA for the Wii (Sep 4th, 2016) and I'm having issues saving with Super Mario Advance 2 - Super Mario World.

Whenever I open up the game, it shows no save at all, and when I complete a stage and choose Save & Quit, whenever I try to load the same save it simply says "Unable to load save" and simply goes into the screen like if it were a new game.

So far it's the only game presenting this issue, all of my other games load and save fine (including GB and GBC games)
Reply
(09-05-2016, 05:54 PM)ShadowOne333 Wrote: I downloaded the latest nightly build of mGBA for the Wii (Sep 4th, 2016) and I'm having issues saving with Super Mario Advance 2 - Super Mario World.

Whenever I open up the game, it shows no save at all, and when I complete a stage and choose Save & Quit, whenever I try to load the same save it simply says "Unable to load save" and simply goes into the screen like if it were a new game.

So far it's the only game presenting this issue, all of my other games load and save fine (including GB and GBC games)
Doesn't that game need some kind of special SRAM patch or something in order to run on emulators? 
Reply
No games should need anything to run on emulators if the emulator is designed well.

You might not have a clean dump, I can take a look a bit later to see what happens to me.
Reply
(09-05-2016, 06:43 PM)fox_whisper85 Wrote: Doesn't that game need some kind of special SRAM patch or something in order to run on emulators? 
Not that I know of.
It was working fine with a previous build from back before middle August I think, I can't recall what build exactly though, but the latest ones starting from September have given me this issue with only that game.

(09-05-2016, 06:58 PM)endrift Wrote: No games should need anything to run on emulators if the emulator is designed well.

You might not have a clean dump, I can take a look a bit later to see what happens to me.
Thanks! Smile

------------------------------------------------------------------

EDIT: The save problem with Super Mario Advance 2 - Super Mario World seems to be affecting other builds as well.
The 3DS CIA build also does the same thing, as does the RetroArch nightlies of the mGBA core, whenever I save and try to load the save again it says "Unable to save" and starts the game from scratch everytime.

EDIT #2:
Okay I redownloaded the game, along with the builds after Sept. 24th and it all seems to be working okay now. Smile
Reply
Dropping by to leave some feedback about the latest development build for both Windows and Wii.
They both seem to have problems booting up Konami Collection Vol. 4 for the Gameboy Color.
I tried Konami Collection Vol. 1 and that seems to be booting fine, only Vol. 4 is giving a black screen on boot.

Thanks for the 0.5.0 update! Big Grin
Reply
I seem to have made a change today that fixed that, so it'll be in tomorrow's dev build!
Reply
(09-26-2016, 02:35 AM)endrift Wrote: I seem to have made a change today that fixed that, so it'll be in tomorrow's dev build!

Ah great!
I'll wait until tomorrow to try it out then.

Thank you for your awesome work! Big Grin
Reply
That's today by now, because timezones, but sure Smile
Reply


Forum Jump:


Users browsing this thread: 5 Guest(s)