Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
video rendering issues under Windows 10 (MGBA 0.30)
#1
When using the OpenGL video renderer and either 57FPS or 60FPS, the video stutters a lot like it's very frequently skipping frames/displaying frames for too long. I assume this is the program conflicting with the compositor under Windows 10.

The Software Renderer doesn't work, or to be more precise it seems the FPS Target is artificially limited to sub 1FPS? Holding Turbo button increases the frame rate of it to over 1,000FPS. Messing with the Target FPS or Frame Rate setting doesn't affect it.

When running v0.30 after upgrading from 0.20 by deleting everything in only the MGBA folder and then installing MGBA 0.30, the FPS Target seems to be sub 1FPS even though the FPS Target setting is visibly set to 57FPS. Settings, had the Frame Rate set to 0.1FPS for some reason. I assume there is a config file not located in the MGBA folder and the new version probably misread the outdated config file. Setting the Frame Rate to 57FPS fixed the frame rate of the OpenGL video renderer. In this particular isntance, adjusting the Target FPS setting would NOT update the Frame Rate setting until after I manually adjusted the Frame Rate setting my self.
Reply
#2
Software renderer is broken with sync to video, and will only work if it's off, which it should be by default.

It's a bit hard to work out what your other problems might be based on the info you've given me, but there's a separate config file in %APPDATA%\mGBA, yes.
Reply
#3
For problem #1 it seems to be skipping 1 or 2 frames every other frame with either renderer, as though Frame Skipping is set to 1 or 2 even though it's set to 0. The problem persists after deleting the configuration files and starting fresh.

Windows 10 x64
Geforce 8800GT
Samsung P2350 60hz monitor
ASUS P6T Motherboard
Integrated Audio
6GB DDR3 1600MHZ RAM
Logitech F310 gamepad
Reply
#4
Try turning down the audio buffer size in settings.

E] Also try a nightly. This might have been fixed by a change a few days ago.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)