Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Permanently disabling end of .sav data in mGBA
Hi, I'm trying to use pkhex on my rom hack and there's a problem. Every MGBA .sav has some sort of computer timestamp at the end which makes it impossible to load into pkhex without deleting it. See here:

On my end:

I saw this post that I thought could help, which talks about game overrides:

I may have been able to export a save without this filler data at the end once, but I definitely have not been able to do so consistently. I never had this problem on my mac, and I'm just now on windows. I tried using the old version of mgba (0.9.1) on windows which didn't do anything, I tried the portable version and the normal installable version and all of these emulators consistently add the junk data at the end of the .sav which really annoys me. Is there any way to consistently have mgba stop adding this extra save data on my windows computer?

I never ever had this problem on my mac. I've tried unchecking the autodetect option and enabling realtime clock with all sorts of save types and nothing has worked. Deleting this filler data at 0x20000 always lets me use pkhex.


Modern versions of PKHeX do support this footer. Are you sure you're up to date?

Also that footer won't be added if RTC is disabled, but it won't be removed either.

Forum Jump:

Users browsing this thread:
1 Guest(s)

Powered By MyBB, © 2002-2024 Melroy van den Berg.