Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu 18.04 binary package
#1
Hello everyone,

I'm a Ubuntu user and I wanted to report that I am having a dependency problem with the binary package for Ubuntu 18.04. Versions till 0.6.3 worked fine, however since version 0.7.0 (including 0.7.1) I get the following message:


Code:
dpkg -i libmgba.deb
Selecting previously unselected package libmgba.
(Reading database ... 342450 files and directories currently installed.)
Preparing to unpack libmgba.deb ...
Unpacking libmgba (0.7.1) ...
dpkg: dependency problems prevent configuration of libmgba:
libmgba depends on libmagickwand-6.q16-6; however:
 Package libmagickwand-6.q16-6 is not installed.

dpkg: error processing package libmgba (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
libmgba


Running a up to date system, 64bit. Any suggestions what to do? Thanks in advance.
Reply
#2
Are you able to install that package? dpkg -i doesn't autoinstall dependencies. I recommend gdebi (in the gdebi-core package) for pulling in dependencies automatically.
Reply
#3
Sure I usually use gdebi-gtk all the time, I just wanted to post some output. Now I realize gdebi can be used without GTK also. Here is the output, again libmagickwand is missing, nowhere to be found in the official repos as well.


Code:
# gdebi libmgba.deb
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libmagickwand-6.q16-6


Thanks for the quick reply endrift!
Reply
#4
Ah I see, it's libmagickwand-6.q16-3 in bionic, but libmagickwand-6.q16-6 in cosmic. Wonder how I messed that up.

E] Should be fixed now in the dev builds! The fix will be in 0.7.2, too. Thanks for reporting this.
Reply
#5
(03-17-2019, 11:27 PM)endrift Wrote: Ah I see, it's libmagickwand-6.q16-3 in bionic, but libmagickwand-6.q16-6 in cosmic. Wonder how I messed that up.

E] Should be fixed now in the dev builds! The fix will be in 0.7.2, too. Thanks for reporting this.

I'm happy I was able to help! Thanks!
Reply
#6
Don't know if this is related or not, but on my latest Gentoo build, mGBA doesn't boot because libmagickwand is now on version 7+, and mGBA keeps trying to read only for the 6.X version of libmagickwand.

I would suggest perhaps adding a check for >=6.X version of Magick, unless the 7.X versions changed things too much to guarantee a safe working environment with mGBA.
Reply
#7
7.x should work fine. It's a compile time issue.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)