Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shader option greyed out...
Hi all, I'm new to mGBA and been trying to figure it out for 2 hours now, but so far no luck. As the title says, I can't get any shaders to work. Maybe I'm stupid, I looked in the options, in the ini file and scoured google, but to no avail.

I'm using the latest nightly (but I tried the stable, too) configured as portable.
Tried to delete the config thinking maybe some setting blocked the use of shaders, didn't help.

Is this feature disabled?

Thanks for taking the time to read all this. ^^

And thanks to the dev for the hard work, he/she no doubt has put into this emulator.

Make sure that the display driver is set to "OpenGL", not "OpenGL (force 1.x)". There's a bug right now where it can get set to force 1.x by default, which disables shaders.

Well that solved my "shader problem" but now I don't have any display at all, I can hear sound just fine, but the screen is black. Tried different games, same thing.
Thanks for your help so far Smile

My specs, if it matters:
Windows 10 x64
AMD FX-6300 @3.8GHz
Radeon R9 270x

Same problem using Xubuntu 14.04 on DELL Latitude D630.

Installing mgba with launchpad . I don't have "mgba" folder in /usr/share/ (i have uncompressed .deb file to copy "shaders" folder Huh ).
Work great in "opengl 1.x..." mode (but shaders greyed out),
Black screen in "opengl" mode, and "load new shaders" (folder with extracted "Shaders") - Sound work

Installing with .deb file (libmgba+mgba-qt+mgba-sdl). The "mgba" folder /usr/share/ exist, but i can see inside only as root.. "Shaders" option greyed in "opengl" and "opengl 1.x..." Works great without shaders


Forum Jump:

Users browsing this thread:
1 Guest(s)

Powered By MyBB, © 2002-2024 Melroy van den Berg.