Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
GBASP shader broken
#1
[Image: en97fbe4w5bvu5y6g.jpg]

I've had this issue ever since I first used mGBA a few months ago. No matter if I reduce the size of the image or tinker with the shader settings, I only get a corner of the screen rendered. Oddly, it doesn't happen with any other shaders.

Screenshot taken on 0.4, but as I said I've had this issue for months.
Reply
#2
I wish you'd told me about this before I released 0.4.0.

What OS, GPU and DPI scaling are you using?
Reply
#3
Sorry. I just thought that somebody surely had come across this issue before me.

Windows 7 x64
nVidia GeForce GTX 760 (GV-N760OC-2GD REV2.0)
My DPI scaling is default. It says it's 96 ppi.
Reply
#4
Just started using the emulator, and I have the same issue with 0.4.0.

Windows 10 x64
Nvidia GTX 970
Default DPI
Reply
#5
Hey there, I believe I have fixed the problem. I messed around with the code in ags001-lights.fs and I think there's a single number that is causing the bug.

On line 16:


Code:
radius = pow(radius, vec2(4.0));


When I chance vec2(4.0) to vec2(2.0) it looks like it fixes the problem.

so in the end it looks like:


Code:
radius = pow(radius, vec2(2.0));


I hope this helps!
Reply
#6
But that's a different formula? It shouldn't change the rendering area, unless the pow function is just broken.

E] Try changing the line to
Code:
radius = pow(abs(radius), vec2(4.0));
and tell me if that fixes it.
Reply
#7
Yup! That seems to fix it as well. I don't think there was a huge difference between what I posted and that. It seems to have made the reflection slightly less bright.

There is however some weird vertical lines that show up whenever something bright is on screen. I'll see if I can get a short video.

Alright, here's a video showing the weird lines. Look on the left and right hand sides.

https://gfycat.com/ImpeccableTestyImpala
Reply
#8
First, make sure resample video is enabled. Some faint vertical lines are by design, but they should only be faint.
Reply
#9
Yeah, Resample Video is enabled. And they are a "faint," I'd say, but prevalent enough to be obnoxious.
Reply
#10
If you mean the super thick ones that are kinda random, then try tweaking the backlight brightness parameter. Otherwise, well, this shader was written as a joke. You can try turning the backlight brightness parameter to 0 and tweak the brightness in other places, or just don't use this shader.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)