Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Games do not automatically boot
#1
I reported an issue here on Github, regarding m-GBA and how ROMs do not automatically boot up upon loading them. I have tried both real BIOS and emulated BIOS modes, skipping the intro, not skipping the intro, and no matter what I do, I have to pause the emulator then resume in order for the ROM to boot up. My issue has been posted here https://github.com/mgba-emu/mgba/issues/48 and I can only hope that eventually, someone looks into it. The versions I tried were 0.21 official and the recent developer builds, neither resolve this issue, and no one else can seem to reproduce it. Would it help if I captured video of it with nVidia Shadowplay and upload it to YouTube to show what I'm talking about? I'm very baffled here and I want to enjoy this emulator even more, I just don't know why the games don't boot up automatically.
Reply
#2
I'm not entirely sure what the problem here may be. I've seen a similar issue, but if you're getting audio when the games (eventually) play, it's not the same issue. I can try to look into this, but without being able to reproduce it, my ability to figure out how to fix it is a bit limited.
Reply
#3
(06-27-2015, 07:13 PM)endrift Wrote: I'm not entirely sure what the problem here may be. I've seen a similar issue, but if you're getting audio when the games (eventually) play, it's not the same issue. I can try to look into this, but without being able to reproduce it, my ability to figure out how to fix it is a bit limited.

That's what I was afraid of, truth be told. Oddly enough, if I fast forward, the game does load, BUT, if I let go of the fast forward hotkey, the game will pause and not automatically resume.  So that would be a no, I don't get any form of audio, but the game does kind of automatically boot, but not really. Secondly, I was afraid this would  happen, file a report for a "bug" that no one else can reproduce, nullifying the importance, yeah, so as such, I feel bad for wasting your guys' time. C'est la vie.  Sad

I don't know what else I can do short of capturing video and uploading it to YouTube, which I have to do now since I'm forever doomed to this bedamned issue. 

Edit: I'll record and upload just what's going on, using both dev and official builds, navigating in menus just to prove that I'm not going crazy, for whatever it's worth, not that'll it do me any good.

Edit 2: Here's my video, not that it'll do any good to getting it resolved.

https://www.youtube.com/watch?v=Q9dPxMJtJCQ

Not trying to be negative, I'm really not, I just feel bad for making this thread and having my assumptions that no one else has this issue beforehand.
Reply
#4
And I'm a f***ing idiot

This whole time, the emulator didn't boot properly because of the stupid QT Multimedia API driver that it was set to by default.

Why is this even an option when SDL works so much better?
Reply
#5
I'd thought about disabling it on Windows. How well it works depends on the OS, but on Windows it's pretty poor. I thought that SDL was the default on Windows? That said, I originally added it because it was necessary for getting multiplayer to work properly, but I eventually managed to wrangle SDL2 into doing what I wanted, as well. It remains in place because SDL1.2 will not work, and hopefully I can fix it to work better someday.
Reply
#6
(06-28-2015, 03:47 AM)endrift Wrote: I'd thought about disabling it on Windows. How well it works depends on the OS, but on Windows it's pretty poor. I thought that SDL was the default on Windows? That said, I originally added it because it was necessary for getting multiplayer to work properly, but I eventually managed to wrangle SDL2 into doing what I wanted, as well. It remains in place because SDL1.2 will not work, and hopefully I can fix it to work better someday.

Well, I don't know now, since SDL is working like a charm where the QT Multimedia API was the culprit, the one that prevented ROMs from booting properly. I don't know why I didn't think to change the sound API, but now, I feel bad because I wasted your time. So yeah, ugh, I apologize for that profusely. Disabling audio sync with QT enabled has no sound and reducing the samples kills performance. SDL is the way for me to go. 
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)