mGBA Forums

Full Version: Fire Red Trading Communication Error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello I'm new to these forums and mGBA. I started a forum account in hopes of getting some help for my Fire Red ROM I'm playing. I'm trying to make sure trading works before I go any further in the game and it seems like it does, to a point. It gets all the way to the point where both instances of my character enter the door to start trading with each other. As soon as they do, it goes to a black screen saying "Communication Error". Has anybody ran into this? Is it possible the ROM I have is just bad? Anybody know how to fix it? I really hope someone could help, maybe even share a known good ROM with me if possible. Thanks.

Solved this shortly after I posted. Seems to work flawlessly on 5.0 mGBA. I'll just use that. Thanks! I'm super happy now.
Don't use 0.5.0. Use 0.5.2 or 0.6.0.
(08-13-2017, 08:12 PM)endrift Wrote: [ -> ]Don't use 0.5.0. Use 0.5.2 or 0.6.0.

Why? It works great in 5.0. Is it somehow better in those versions?
0.5.0 is pretty crash-prone with savestates and can destroy savestates in the process.
Eeek! Thanks for the headsup.
Agonizingly it seems Joseph didn't share how he fixed his issue as I am currently experiencing this problem in Pokemon: Emerald. I have reached up to the same point as he when the error happens but I have had no such luck fixing it. Is there any form of troubleshooting process that can help me pin down the issue and get this resolved?
At least for the benefit of people who encounter this issue years in the future and can find only one or two threads that discuss the problem but not how it's solved.
I am using 6.0, the current version of mGBA.
Issue appears to be resolved! ARRRGH it worked ONCE! And when I forgot to have the pokemon I needed to trade on hand. Back to fumbling around...
I woke up this morning realizing "Oh hey, I never checked to see if I was running a 64 bit version of the emulator". Checking the downloads, sure enough I didn't. The 64 bit version seems to be working fine, worked once, though I had to look in 'old releases' to find it for the current version of the emulator.

Could I trouble you, endrift, to add a link to the current 64 bit release of 6.0 for Windows to the main downloads page? Thank you in advance.

Final edit: I give up. After working once it's just never going to work again despite the twelve subsequent times I've tried. No way to tell what's wrong and no way to solve the issue. I guess I'll check back on this emulator if it ever fixes this issue in a new release.
Yeah, it's an emulator bug, not a problem on your end. I'm hoping to redo multiplayer significantly in the next release.
(09-29-2017, 12:30 AM)endrift Wrote: [ -> ]Yeah, it's an emulator bug, not a problem on your end. I'm hoping to redo multiplayer significantly in the next release.

Did you make some Good Headway in version 0.6.1?
(08-13-2017, 08:12 PM)endrift Wrote: [ -> ]Don't use 0.5.0. Use 0.5.2 or 0.6.0.

I've tried both, but it doesn't seem to work for me Undecided Any suggestions? 6.0 won't even load the second game for me. Instead I just get a white screen. 5.2 will load both games but it gives me the communication problem after I enter the trade room.
Pages: 1 2